How to make TOUGH2-MP v2.01

Hi, everyone. I have TOUGH2-MP v2.01 source code, and try to make execution file with below step.

1, "make configure" at tough2.01-mp. (modified Makefile:  CC=icc, FC=ifort)

2, "make" at tough2.01-mp/build/Linux-x86_64-eco2n-Debug

And, errors occur like below.

ifort  -DTF_ECO2N -fpp -free -g -O0 -debug all -traceback -r8 -i4 -check all -fp-stack-check -fpe0 -fpconstant -vec_report0 -diag-disable 8291 -I -g -module modules -I/tough2.01-mp/src -I/tough2.01-mp/build/Linux-x86_64-eco2n-eco2n-Debug/tpls/include    -c /tough2.01-mp/src/Data_DD.f90 -o CMakeFiles/subdir_mods.dir/Data_DD.f90.o

tough2.01-mp/src/Data_DD.f90(45): error #5102: Cannot open include file 'mpif.h'
    include 'mpif.h'

------------^

 

I think "ifort" command is wrong, and would like to replace it with "mpif90". But, I don't know how to do it.

 

Best regards.

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Nori,

    it seems that mpi is not setup properly (or not installed) on your machine and it can't find the mpi libraries. What does "whereis mpirun" or "whereis mpiexec" gives? If it can't find anything, then you need to install mpich (or openmpi... not sure).

    Charlotte 

    Reply Like
  • Nori,

    Yes, please make sure you have mpif90 and mpicc first. Then set make config eos=eco2n CC=mpicc and FC=mpif90.

    George
    Reply Like
Like Follow
  • 4 yrs agoLast active
  • 2Replies
  • 885Views
  • 3 Following