0

INSTALL OF TOUGH2

I purchased Tough2 software and i want to run it using PC 64, 8 proccesor, but i couldnot, please can any one you help me in running the software and to run an example, I read the instruction given with the software but it is complicated. Please give me the procedure to run it because i am biginner. I have the source code and ECO2N executabile. I need the first step to compile COMPILATION/LINKING/EXECUTION OF TOUGH2. I attache the read me file.
Best Regards

36replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Manuel Rivera
    • Geothermal reservoir engineer at Mercury NZ Ltd.
    • Manuel_Rivera
    • 5 yrs ago
    • Reported - view

    Stefan,

    I do not have EOS3 compiled. But I ran a different example, the 5-spot production-injection problem, which I believe uses EOS1, and the result was the same.

    
    marivera@MARIVERAWS2 ~/Documents
    $ tough2 sam3 1
    
    ++++++++++++++++++
    + iTOUGH2 started: -tough2 sam3 1
    ++++++++++++++++++
    sed: can't read sam3.out: No such file or directory
    /bin/mv: cannot stat 'sam3.sav': No such file or directory
    /bin/rm: cannot remove '*.plo': No such file or directory
    
    
    Temporary directory /home/marivera/it2_8460 not removed!
    
    ++++++++++++++++++++
    + iTOUGH2 completed: -tough2 sam3 1
    

     

    I attached the contents of the temporary directory.

    Like
  • Hi Manuel,

    I cannot reproduce the issue, and I probably do not have access to the (somewhat strange and 8-year old) version you seem to have. Please try one of the following "workarounds" for running iTOUGH2 in forward mode:

    (1) Create a dummy iTOUGH2 input file (it could actually be an empty file); call it "forwardi"

    (2) Instead of using the tough2 script, use the itough2 script, i.e., type:

    itough2 forwardi sam3 1

    (3) If this does not work, try using the executable directly (rather than the script), i.e., type:

    /home/marivera/itough2/Executable/itough2_1.MARIVERAWS2

    Then enter "forwardi" and "sam3" when prompted.

    (4) Have you tried an inverse run, i.e.:

     itough2 sam3p1i sam3 1

    (5) Check read/write/exe permissions and full path to /home/marivera/it2_* and Documents, etc.

     

    That's all I can offer right now.

     

    Stefan

    Like
    • Manuel Rivera
    • Geothermal reservoir engineer at Mercury NZ Ltd.
    • Manuel_Rivera
    • 5 yrs ago
    • Reported - view

    Dear Stefan,

    Unfortunately none of them worked, but thank you anyway for the help.  I am using the license of LaGeo in El Salvador. It is kind of old but is the one we have been using here for a while.  I guess I'll stick to linux for running TOUGH2.

    Have a nice day!

    Like
  • Hi Stefan, 

    We have purchased the source code, and I see the executable files of different EOS in PC-executable folder. 
    I used the samples from folder "eos7ca" and run it using "tough3-eos7ca.exe" but it gave me error in processing. It seems that the model runs and finishes at time zero. I copied the screenshot of the results here. 
    I wonder if the problem is with the input file or it is generated because of the executable file. I need your help with that issue and I am thankful if you could help me. 

    Like
  • Hi Shirin,

    I do not see any error here. It seems the input file asks to run 1 time step, which is set to 1.e-9. And that is exactly what the code did.

    Please make sure you post your message with correct information to get proper help (e.g., you are running TOUGH3 not TOUGH2).

    Thanks

    Yingqi

    Like
      • Shirin
      • Shirin_Samani
      • 2 yrs ago
      • Reported - view

      Yingqi Zhang  thanks for your answer. I see the model runs for 1e-9 sec, but I got confused why all the other numbers are zero. For example, model computation, calculation time, and input time are zero.  

      Like
    • Shirin This is a very small problem, and with today's fast computer it hardly takes time for reading input and model computation etc.

      Yingqi

      Like
Like Follow
  • 2 yrs agoLast active
  • 36Replies
  • 3292Views
  • 10 Following