0

INSTALL OF TOUGH2

I purchased Tough2 software and i want to run it using PC 64, 8 proccesor, but i couldnot, please can any one you help me in running the software and to run an example, I read the instruction given with the software but it is complicated. Please give me the procedure to run it because i am biginner. I have the source code and ECO2N executabile. I need the first step to compile COMPILATION/LINKING/EXECUTION OF TOUGH2. I attache the read me file.
Best Regards

36replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Ermad,

    Please let me know what compiler you have. I have to assume that you are familiar with your Fortran compiler. At which step in the process of compiling and linking TOUGH2 do you run into problems?

    Also note that you have been given an executable (look for it in directory TOUGH2_ECO2N/Executable_ECO2N) - i.e., you don't need to compile the code yourself; just follow the instruction for running TOUGH2.

    Good luck!

    Stefan

    Like
      • Shirin
      • Shirin_Samani
      • 2 yrs ago
      • Reported - view

      Stefan Finsterle 

      Hi Stefan, 

      I should change something in source code and then create the executable file, but I do not know how to create executable file from the source code. I am thankful if you help me. I have Cygwin to create the exe file.  

      Like
      • Stefan Finsterle
      • Finsterle GeoConsulting
      • Stefan_Finsterle
      • 2 yrs ago
      • Reported - view

      Shirin Samani 

      Dear Shirin,

      Let me suggest that you ask your questions by addressing the entire TOUGH Forum community, not just me. You have a much higher chance of getting an answer. Note that everybody answering questions on the Forum does this on his/her own time, so it is important that we share this load.

      Please make use of the search feature of the Forum. You will see that your question has been asked and answered many times before.

      The official TOUGH distribution comes with a read me file that explains how TOUGH has to be compiled. However, it cannot be the purpose of the read me file or this Forum to explain fundamental tasks such as installing a compiler, compiling a Fortran code or using operating system commands, some of which depends on your computer and software installations, so cannot be answered universally. Since you are capable of making code changes, I assume you know how to compile a Fortran source code on your particular machine.

      The short answer to your question is: Install cygwin and a Fortran compile (e.g., gfortran), then compile and link all the source code file as listed in the TOUGH manual and/or the read me file. Set appropriate compiler options to invoke 64-bit arithmetic and disable array-bound checking.

      Good luck,

      Stefan

      Like
      • Shirin
      • Shirin_Samani
      • 2 yrs ago
      • Reported - view

      Stefan Finsterle 

      Dear Stefan, I was reading the thread you answered some question, and that was the reason I mention you. Sorry that I addressed that question to you. Thanks by the way for answering my question. 

      Like
      • Stefan Finsterle
      • Finsterle GeoConsulting
      • Stefan_Finsterle
      • 2 yrs ago
      • Reported - view

      Shirin 

      Hi Shirin,

      Thanks for letting me know - good luck!

      Stefan

      Like
  • Hi Stefan

    Yes I have the excutable, and when I tried to run it i obtained the attache picture

    what I have to do in order to make the simulation run?

    Could you tell me which files exactly i have to put it with the excutable folders in order to get the simuator running?

    could you tell me please what steps Ican follow to run it.

     

    Rgards

    Emad

    Like
  • Emad,

    Please follow the instructions in the read.me file, the manual, previous posts in this Forum, or the attached installation instruction file. To run TOUGH2 with the input file "example.inp", do the following:

    (1) Open a DOS Prompt Command Window (i.e., don't just double-click on the executable)

    (2) Change to your working directory (e.g., type "cd C:\MyTOUGH\HereAreMyInputFiles"

    (3) Make sure the executable xt2_eco2n.exe is in this directory, or add the directory where the executable resides to your command search path (see attached file).

    (4) Now type:

    xt2_eco2n.exe < example.in > example.out

    (5) Use a text editor with 132 columns and Courier font to examine the output file example.out

    Hope this helps.

    Stefan

    Like
  • Thank you very much, I have installed the software

    Emad

    Like
  • Hello Stefan, I have a lot of problems installing the software because I don´t have the executable file so I compiled each file, T2, MESHM, EOS3 (as an example), MA28, T2f, T2CG22, T2SOLV with the instruction gfortran -o xt2_eos3 -g -fdefault-real-8 -falign-commons / 

    T2.f  MESHM.F EOS3.F MA28.F T2f.f T2CG22.F T2SOLV.F

    But it doesn't work! I am using gfortran in MS-Dos, Help!

    Ana.

    Like
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 6 yrs ago
    • Reported - view
    Can you post your error message?
    Like
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 6 yrs ago
    • Reported - view
    At some point this worked (using MinGW):
    
        gfortran -c -O2 -fdefault-real-8 -fno-align-commons -fdefault-double-8 -funroll-loops t2cg2.f meshm.f eos1.f t2f.f ma28.f t2solv.f
        gfortran -O2 -fdefault-real-8 -fno-align-commons -fdefault-double-8 -funroll-loops -static -o tough2_1 *.o
    
    Like
  • Ana,

    I agree with Andri: Please let us know what error messages you have, as they will indicate what the issue might be. I also noticed that you renamed T2 to T2.F and tried to compile it. T2 is an include file; rename T2.F back to T2 (i.e., without an extension) and remove it from the files being compiled.

    Stefan

    Like
  • Hello, this what I have done in my compiler. Ok I will remove the extension. Thank you, Ana.

    Like
  • Hi Ana,

    Please see the replies to the following post regarding the CPU-time function SECOND:

    https://tough.forumbee.com/t/633bj3

    Stefan

    Like
  • Ohh it worked. Thank you so much.

    Ana.

    Like
  • Hello Everyone,

    I followed the instructions above in order to obtain the T2CG2 excutable file. I am using gfortran in Cygwin, but it give me these errors:

    Cortesia@Cortesia-PC /cygdrive/c/TOUGH2/Tough2v2.0R
    $ gfortran -c -O2 -fdefault-real-8 -fno-align-commons -fdefault-double-8 -funroll-loops T2CG2.F
    T2:84.1:
        Included at T2CG2.F:101:

    \x1A
        1
    Error: Non-numeric character in statement label at (1)
    T2:84.1:
        Included at T2CG2.F:1835:

    \x1A
        1
    Error: Non-numeric character in statement label at (1)
    T2:84.1:
        Included at T2CG2.F:2024:

    \x1A
        1
    Error: Non-numeric character in statement label at (1)
    T2:84.1:
        Included at T2CG2.F:2208:

    \x1A
        1
    Error: Non-numeric character in statement label at (1)
    T2:84.1:
        Included at T2CG2.F:2585:

    \x1A
        1
    Error: Non-numeric character in statement label at (1)
    T2CG2.F:2698.9:

             iijjkk(n2) = iijjkk(n2)+1
             1
    Error: Unclassifiable statement at (1)
    T2CG2.F:2816.1:

    \x1A
        1
    Error: Non-numeric character in statement label at (1)
     

    barbara

    Like
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 6 yrs ago
    • Reported - view

    Could be a hidden character. Is there a blank line at the end of the T2 file? If so you can try to delete it or if cygwin has the dos2unix utility you can try to strip the hidden characters from your *.F , *.f and T2 files (dos2unix *.F *.f T2)

    Like
  • Dear All,

     

    I tried to compile after installing cygwin but I have the same error as Barbara. How can I solve this? I tried the dos2unix but it did not work...

    Thank you in advance for your help!

    Virginie

    Like
  • Virginie,

    Make sure there are no tabulator stops in the source file. Just check line 84 of T2.

    I'm surprised that you plan to compile t2cg2.f - this file has been outdated for about 15 years.

    Stefan

    Like
  • Hi Stefan,

     

    Thank you for your answer. I removed all the tabulators stops in the .f files + removed the call to CPUSEC and it solved the problem. In addition, I used t2cg22. In cygwin, to compile and link, I typed:

    gfortran -o xt2_eos1 -g -fdefault-real-8 -funroll-loops -fdefault-double-8 -fno-align-commons -fbacktrace \EOS1.F t2cg22.f meshm.f t2f.f t2solv.f ma28.f
     

    I just got warnings. So it looked OK. However when I run the code, I get the following message: 

    ./xt2_eos1 <sam1> sam1.out                                                    

    Note: The following floating-point exceptions are signalling: IEEE_DENORMAL
     

    How can I avoid this???

    Virginie

    Like
  • I forgot one thing: I need to add ma28.f in the list of files to be compiled and linked otherwise it does not work. Could it be that I do not have the latest versions of the files??? If so, how can I get the updated files?

    Thank you in advance for your reply!

    Virginie

    Like
  • Virginie,

    Try one of the following compiler options:

    -g -fbacktrace -fdefault-real-8  -falign-commons -fno-automatic -finit-local-zero

    or

    -fdefault-real-8 -fno-align-commons

    I don't know which gfortran compiler version you have - there are slight differences (I'm surprised that you do not need to specifically disable array-bound checking during run time.

    Usually, sam1 is run with EOS3, not EOS1 (but it should work as well; just don't expect the same results as those you see in the manual).

    It is obvious that you are using a (very) old version of TOUGH2. The version you have was not distributed by LBNL and is no longer available. It even appears you may have a mix of versions (the old instructions clearly indicate that you need to add ma28.f). The latest versions can be found here:

    http://esd1.lbl.gov/research/projects/tough/licensing/

    Best,

    Stefan

    Like
    • Manuel Rivera
    • Geothermal reservoir engineer at Mercury NZ Ltd.
    • Manuel_Rivera
    • 5 yrs ago
    • Reported - view

    Dear all,

    I have been successfuly using iTOUGH2 V6.4 (January, 2009) in a linux computer. Now I am trying to compile it in a Windows 7 machine in cygwin at first (no success) now through MinGW (No success either), using gfortran in both cases. 

    The file listing in my SourceCode folder is in "files.txt"

    in cmd, I type:

    gfortran -c -O2 -fdefault-real-8 -fno-align-commons -fdefault-double-8 -funroll-loops t2cg22.f meshm.f eos1.f t2f.f t2solv.f

    The files t2cg22.o meshm.o eos1.o t2f.o and t2solv.o files are created.

    Then I run:

    gfortran -O2 -fdefault-real-8 -fno-align-commons -fdefault-double-8 -funroll-loops -static -o tough2_1 *.o

    an I get  an error: "collect2.exe: error: ld returned 1 exit status. " Screenshot in file screenshot.png

    Any advice? Thanks in advance.

    Manuel

    Like
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 5 yrs ago
    • Reported - view

    Have you tried the it2make script while in cygwin? That "should" work.

    If not, make sure to delete all .o and .mod files in your directory - there is some confusion between iTOUGH2 and TOUGH2 files.

    Then compile it2main.f, it2input.f, it2xxxx.f, it2user.f, mdeplinux.f, t2cg22.f, t2solv.f, eos1.f, t2f.f, meshm.f, it2stubs.f sequentially using the -c option (to not link them yet into an executable).  

    Once you have all the .o files again, try to link them into an executable, gfortran *.o -o itough2_1. You might run into problems with the SECOND subroutine since it is an intrinsic function in gfortran.  

    As for compiler options you can try "-c -O3 -fsign-zero -ffree-line-length-none". 

    Like
    • Manuel Rivera
    • Geothermal reservoir engineer at Mercury NZ Ltd.
    • Manuel_Rivera
    • 5 yrs ago
    • Reported - view

    Hi Andri,

    Thank you for the quick and effective answer.  it2make 1 in cygwin told me:

    * V6.4, S. Finsterle, Lawrence Berkeley National Laboratory, January 2009
    * Unix platform CYGWIN_NT-6.1 not supported by it2make.
    * Please send e-mail to SAFinsterle@lbl.gov.
    * ERROR: No iTOUGH2 executable created.
     

    But compilation and linking of the files you suggested did work :) and produced the .exe file.

    Thanks a lot.

    Like
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 5 yrs ago
    • Reported - view

    Good to hear, and good luck!

    Like
  • Manuel,

    To make it2make work, simply edit file it2make, search for "COM=linux" and add the segment in bold:

    elif `uname|grep -i linux >/dev/null` || `uname|grep -i cygwin >/dev/null` ;
    #
    # LINUX
      then COM=linux ;
    #
    

    Hope this helps.

    Stefan

    Like
    • Manuel Rivera
    • Geothermal reservoir engineer at Mercury NZ Ltd.
    • Manuel_Rivera
    • 5 yrs ago
    • Reported - view

    Dear Andri and Stefan,

    I am having problems using the executable compiled using the above instructions under cygwin.

    I run tough2 and get the message shown in figure 1.

    Temp folder is created. Contains files invdir, invdir.msg, invdir.out, itough2.fil, itough2.ver, sam1.

    The file invdir.msg says this:

     =========================================================================
     i T O U G H 2 _ 1  R U N  date: Thu, Mar 16, 2017  9:32:47 AM
     =========================================================================

    Command submitted: /home/marivera/bin/itough2 -tough2 sam1 1

    STOP Error in OPENFILE

     *****  ERROR  *****
     * File >>>invdir<<< not found in directory >>>/home/marivera/it2_10172<<<!
     *****  ERROR *****
    cat: invdir.err: No such file or directory
    /bin/rm: cannot remove 'invdir.err': No such file or directory
    cat: '*99*': No such file or directory

     

    A little bit about my setup:

    itough2 home is in /home/marivera/itough2. The sub-folder /Executable contains itough2_1.MARIVERAWS2.

    folder /home/marivera/bin contains the scripts itough2 and tough2.

     

    Thanks in advance.

    Like
  • Manuel,

    I'm puzzled by you actually seeing invdir in the temporary directory. Can you open it?

    This may be unrelated, but in case "sam1" is the iTOUGH2 Sample Problem 1, please note that you need to run it with EOS3 (not EOS1), i.e., type:

    tough2 sam1 3

    Should the not resolve the issue, please send me all files you find in your temporary directory.

    Best,

    Stefan

    Like
Like Follow
  • 2 yrs agoLast active
  • 36Replies
  • 3294Views
  • 10 Following