"ERRONEOUS DATA INITIALIZATION" on IBM-AIX cluster

I encountered a problem with "ERRONEOUS DATA INITIALIZATION" , when I  tried to run serval tests using TOUGH2-MP on IBM-AIX cluster.  These tests had been successfully tested using the usual Tough2. 

The full error information is below,

 time for preprocessing ---- including data input,     partition, distribution:  0.118824958801269531     
 }}}}}}}}}}} ERRONEOUS DATA INITIALIZATION }}}}}}}}}}           STOP EXECUTION----------    2

 

and the output file is always ended as following near giving the information of MOPs.

------------------------------------------------------------

....

   MOP(24) = 0 *** PERMITS TO SELECT HANDLING OF MULTIPHASE DIFFUSIVE FLUXES AT INTERFACES
           = 0: HARMONIC WEIGHTING OF FULLY-COUPLED EFFECTIVE MULTIPHASE DIFFUSIVITY
           = 1: SEPARATE HARMONIC WEIGHTING OF GAS AND LIQUID PHASE DIFFUSIVITIES.

 ****printout finished here ************************

Could anyone help me fix this problem? Thank you!

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • The volume of OUTPUT_DATA is 0.

    Reply Like
  • Hi Eomi,

    just guessing here: could it be an issue with precision of data, time in particular. E.g. if you are using an INCON file with conditions for a certain time 0.001 but your simulation start time is 0.0 the code would not find conditions for time 0.0. (though I think there would be a different error showing in your output file for exactly that case). But since you say it works with "usual Tough2" , but not with MP version which can operate at higher precision...

    Reply Like
  • Judi, thank you very much for your reply. I have checked the problem again by setting printout for INFILE content. I find the printout for the mesh is not included, compared to the printout of a run using Tough2. I guess this could be a problem under IBM-AIX UNIX in text encoding, though I have changed the CRLF to LF line return. Previously, I had the experience to run TOUGH2MP under Ubuntu system, which didn't have this problem.  Thank you.

    Reply Like
  • The printout is listed for reference.

         DOMAIN     MAT        DENSITY        POROSITY     CONDUCTIVITY     HEAT CAP       COMPR          EXPAN
            3      ENDL      0.2600E+04     0.1000E+01     0.2510E+01     0.9200E+03     0.4500E-09     0.0000E+00

                PERM1          PERM2          PERM3
              0.1000E-04     0.1000E-04     0.1000E-04

         *********************************************************************************************************************

         ELEMENTS

                  ELEMENT         MATERIAL         VOLUME
         *********************************************************************************************************************

         CONNECTIONS

                    ELEM1            ELEM2             ISO             DEL1           DEL2            AREA           BETA

         *********************************************************************************************************************

    No content!!!!!!

    Reply Like
  • It seems strange that the TOUGH2MP executer has already correctly read the MESH file and printed following information in the printout.executer

     MESH HAS     3000 ELEMENTS AND     8300 CONNECTIONS (INTERFACES) BETWEEN THEM 
    But following this information, there is no printout of ELEMENT name and volume as I showed above. In addition, after a run, the MESHA and MESHB are also created with volume larger than 0.

    Reply Like
  • When I directly put the MESH content into INFILE, the correct MESH, MESHA and MESHB can be produced after a run. However, within OUTPUT, the printout still cannot show ELEMENTS and CONNECTIONS in detail. It also just shows the initial condition of a few cells among total 3000 elements. 

         *********************************************************************************************************************

         CONNECTIONS

                    ELEM1            ELEM2             ISO             DEL1           DEL2            AREA           BETA

         *********************************************************************************************************************

         INITIAL CONDITIONS

                   ELEMENT       POROSITY         X1             X2             X3             X4

                   A11 1        0.2200E+00     0.1000E+08     0.3200E-01     0.4600E-03     0.3500E+02
                   A21 1        0.2200E+00     0.1000E+08     0.3200E-01     0.4600E-03     0.3500E+02
                   A31 1        0.2200E+00     0.1000E+08     0.3200E-01     0.4600E-03     0.3500E+02
                   A41 1        0.2200E+00     0.1000E+08     0.3200E-01     0.4600E-03     0.3500E+02
                   A51 1        0.2200E+00     0.1000E+08     0.3200E-01     0.4600E-03     0.3500E+02
         *********************************************************************************************************************

    Reply Like
  • Though the compile of TOUGH2MP seems successful, I guess perhaps it has problems in data conversion.

    Could someone give me a makefile for Tough2MP working under IBM-AIX? Thank you!

    Reply Like
  • The problem has been solved by recompiling the Aztec lib using MPI com. Previously I used serial com. Thank you for your attention. 

    Reply Like
reply to topic
Like1 Follow
  • 1 Likes
  • 1 yr agoLast active
  • 8Replies
  • 383Views
  • 2 Following