Warning about Convergece

Hello, I'm new in iTough2. It's been a while since the lecture given by Stefan back in New Zealand 2014, at UoA. 

I'm having a converge issue while triying to run a steady state and then a transient model. I have tried to manage it with the ">>> stay alive" command, and also with" >>> 30 CONSECUTIVE".  But with the last option the *.out file shows me:

 

*****  WARNING  *****
 *  3 ambiguous keywords found near line  256:
 *          >>> accept: 30 CONSECUTIVE time steps that converge on ITER=1
 * Keyword No. 2 is interpreted!
 *     1 : STEP
 * --> 2 : CONSECUTIVE
 *     3 : ITER=1
 *****  WARNING  *****

 

If I run the forward model separately for the natural state and the transient, works fine. But when I tried to run the calibration for both of them at the same time it does not finish the first transient Tough2 run, as appears in the text below:

 

 ****  MESSAGE  *****     1: Assumed steady state (IQIT= 0). Time = 2.12360E+14 [sec]. Start transient run now.                                                        

 *****  WARNING  *****  Run No.   1 failed: too many consecutive time steps that converged on ITER=1. iTOUGH2 tries to stay alive.
 

Is it the interpreted keyword the mistake I have? that one do not let me handle the warning situation?

 

Also, I tried to separate the calibration and they work just fine, I can calibrate the natural state in one itough2 run and then calibrate the transient in another itough2 run.

 

Hope you can help me.

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Marco,

    The easy question first: Remove the words "step" and "ITER=1"from the command line that contains the command "CONSECUTIVE" to avoid the warning message. (Always resolve warning messages, unless you clearly know that it means! In fact, the one here should have no impact whatsoever, so it would be okay to leave it unresolved.)

    The second issue you saw is more difficult to address: If you are able to run the model in forward mode through both the steady-state natural-state and transient production periods, it should be able to do the same during an inversion - specifically the first run -  unless you (a) changed the parameter values in the iTOUGH2 input deck, and/or (b) added calibration points that force iTOUGH2 to take very small time steps.

    I don't know whether you ran the forward simulation without an iTOUGH2 input file, or with an iTOUGH2 input file that contains the command >>> FORWARD. If the former, try the latter, then look at when the convergence failure occurs, and specifically check time steps enforced by the calibration points - they may be very small.

    If you already did all that, and the problem persists, I would have to see your input files.

    Good luck,

    Stefan

    Like
Like Follow
  • 2 mths agoLast active
  • 1Replies
  • 16Views
  • 2 Following