Error Codes?

Long story short I'm trying to run a very large forward model in iTOUGH2 and have probably narrowed down my problem to having not compiled an appropriate version with enough elements/connection in maxsize.inc (tomorrow's work!). 

Im getting an Error code of 185. However for the life of me I cant seem to find a list of error codes in either the iTOUGH2/TOUGH users guide. Basically am I being an idiot and not looked hard enough?

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 2 yrs ago
    • Reported - view

    Can you provide the input/output file or more detailed print out from the error message. Most likely the message error depends on the compiler you have used.

    Reply Like
  • Hi Andri, I've attached the model directory containing inputs and outputs.

    The command I use to run is;

    itough2 -i incon invfile flow.inp 7&

    It seems to work fine for smaller 2D files  I have been running.

     

    Also I have tried to compile a new version editing maxsize as such;

    MAXEL=399999 (my total Elements in flow.inp = 340,399)

    MAXCON=1000000  (my total connection in flow.inp = 994,385)

    However the max sizes I have been able to use are 199999 and 500000 respectively. Do you know if this is/there is a maximum limit for EOS7?

    Thanks for your assistance in this matter, it's greatly appreciated!!

    Reply Like
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 2 yrs ago
    • Reported - view

    Could be something as simple as this executable appears to be for EOS3 but your input files for EOS7.

    And this executable only allows for 99999 elements.

    Reply Like
  • Hi Hamish,

    The error message 185 just says that an error in the forward run occurred, which is related to the fact that your major arrays are not properly dimensioned, as you have already found out.

    As Andri, I'm confused about which EOS you want to use (3 or 7?) . The output files you sent were run with EOS3, and the corresponding executable did not have a high enough MAXEL and MAXCON. But the INCON file is for EOS7. Please recompile iTOUGH2-EOS7 and let us know what happens.

    Stefan

    PS: Thanks Andri for answering iTOUGH2 Forum posts!!!

    PPS: The new iTOUGH2 - to  be released in a couple of months - will have dynamic memory allocation - no more maxsize.inc!

    PPPS: I ran your input file with my version of iTOUGH2 - it runs just fine.

    Reply Like
  • Hi guys, 

    Thanks so much for both of you taking time to answer. Yes apologies for that I copied the wrong directory in haste from when I tried an EOS3 sim earlier...

    Again attached are the out files which should show that EOS7 was called and that I had a 185 Error. This is using 150,000 Elements and 500,000 connections and given my model has more than that (see previous) this error is explainable. Also included is a 'log' of the various errors when I change values in maxesize.inc with comments/new attempts in red.

    I was thinking of including my version of the Source Code (or rather just makesize, it2make, makefile) in there but realized this would be unwise given licensing! If you think having a look at this could help I'd be happy to email this your personal email address(es)?

    Once again, much appreciated!

    Hamish

    ps: A couple of months? :) Just in time for Christmas, I know what I'll be asking Santa for! 

     
    Reply Like
  • Hamish,

    Sorry, I don't understand. Your model has about 340,000 elements, and about 1,000,000 connections. So you have to dimension MAXEL and MAXCON accordingly.

    Stefan

    Reply Like
  • Yes I was just showing that I was in fact using EOS7 and not EOS3.

    Sorry I should have made it clearer in my previous comment that my problem is that I cannot compile a version of iTOUGH2 using EOS7 with values of MAXEL>150000 and MAXCON>500000.

    Im changing them in maxsize.inc so this is what the relevant section looks like

    C$$$$$$$$$ PARAMETERS FOR SPECIFYING THE MAXIMUM PROBLEM SIZE $$$$$$$$$$
    C
    C **********************************************************************
    C iTOUGH2 and TOUGH2 parameter statements
    C **********************************************************************
    C
    C --- MAXTIM   : Maximum number of calibration times 
    C                plus number of printout times
          INTEGER MAXTIM
          PARAMETER (MAXTIM=1000)
    C
    C **********************************************************************
    C TOUGH2 parameter statements
    C **********************************************************************
    C
    C --- MAXEL   : Maximum number of elements
          INTEGER MAXEL
          PARAMETER (MAXEL=499999)
    C
    C --- MAXCON  : Maximum number of connections
          INTEGER MAXCON
          PARAMETER (MAXCON=1000000)
    C
    C --- MAXK    : Maximum number of components/species
          INTEGER MAXK
          PARAMETER (MAXK=2)
    C
    C --- MAXEQ   : Maximum number of equations per block
          INTEGER MAXEQ
          PARAMETER (MAXEQ=3)

     

    I've commented the various attempts in the file Log_iTOUGH2-EOS7install attached in previous comment and again bellow

    Reply Like
  • Hamish,

    It seems you're running out of memory during linking. Try to add "-mcmodel=medium" to the compiler options COO in it2make (attach your it2make if you need help doing this). gain, eventually you need to increase MAXEL and MAXCON.

    By the way: there should be no need to remove the executable each time before you recompile, as long as you make a change in any of the .f or .inc files.

    Let me know how it goes (or not).

    Stefan

    Reply Like
  • Hey Stefan, 

    It seems to have worked!! (Might be another month before I see if the output looks sane)

    For the forum record I complied using the command:

    ./it2make -co -mcmodel=medium 7

    Thanks once again for both your's and Andri's effort!

    Cheers, Hamish

    Reply Like
    • Andri Arnaldsson
    • Senior Geothermal Scientist - Vatnaskil Consulting Engineers
    • Andri_Arnaldsson
    • 2 yrs ago
    • Reported - view

    Good to know that the issue is solved - too bad that the mcmodel option usually results in longer execution times. Given the number of elements and connections your model has I'm a little bit curious about your run times. 

    Reply Like
Like Follow
  • 2 yrs agoLast active
  • 10Replies
  • 692Views
  • 3 Following