0

Restart time in inchem file is not the same as starting time in INCON - 1D Radial CO2 injection - Problem 5

Hello, 

I removed the GENER block from the flow.inp file in order to run an equilibration simulation for 10,000 years. I then wanted to use the 10,000th year data to be used as my initial conditions for the next simulation I ran. 

Since the produced SAVE file from the 10,000 year simulation exceeds fortran format, I replaced the bottom two lines of SAVE with the following: 

+++  
     1     1  1 0.00000000E+00 0.31536000E+12

*(There are five spaces before the first 1)

When I run the second simulation, everything works correctly. However, I get a note on the terminal saying the following:

"Restart time in inchem file is not the same as

starting time in INCON

timetot= 94608000000.0000 tstart= 0.000000000000000E+000

Continuing Simulation (Check Inputs!)"

I have attached two zip files of what I did in order to run the two simulations for reference. 

What is the issue with the way I am running the simulation? Also, what are the ramifications of running the simulation in this way? 

Kind regards,

Majid

2 replies

null
    • TOUGHREACT Developer
    • Eric_Sonnenthal
    • 1 yr ago
    • Reported - view

    Hi Majid,

    The end time in flow.inp was only 1000 years, rather than 10,000 years. That fixed this problem. However, then the GENER block inside flow.inp also did not extend to the end time, so that caused a crash. Make sure you also remove the old GENER file created in the folder before running. Here are the two fixes:

    PARAM----1----*----2----*----3----*----4----*----5----*----6----*----7----*----8
       49999    9999000000000001000400005000
              3.15569E11       -1.  8.640E04A1 48 0.01      9.81
     

    GENER----1----*----2----*----3----*----4----*----5----*----6----*----7----*----8
    A1  1inj 1                   3     COM3h            .538E+05       
        0.0000E+00   3.15576E+11    3.15576E12
              90.0    0.0000E+00    0.0000E+00
          .538E+05      .538E+05      .538E+05
     

    The next run goes very fast. However, you may want to adjust your starting and end times to get exactly 10 years, since I think this was only about 6 years injection.

        ----------- TOUGHREACT V4.13omp  -------
                           EOS 14
               Lawrence Berkeley National Laboratory   
                        Jan 10, 2022

    ***** OpenMP Parallel Code Settings **** 
        *** maximum number of threads allotted  =  16
        *** maximum number of threads available =  16

    --> reading multiphase flow input (flow.inp)
            Running ECO2N V2.1, maximum T(C) allowed =   105.000000000000     
        --> reading solute transport input (solute.inp)
        --> reading chemical input (chemical.inp)
        --> Start reading thermodynamic database: TherAkin10.dat      
        --> reading of initial input data complete
        --> reading reactive transport restart file (inchem)

    --> performing simulation

        END OF TOUGHREACT V4.13omp  SIMULATION

        ELAPSED TIME =      5.191 SEC   CALCULATION TIME =      5.187 SEC   DATA INPUT TIME =     0.005 SEC
     

    cheers,

    Eric

    • TOUGHREACT Developer
    • Eric_Sonnenthal
    • 1 yr ago
    • Reported - view

    Hi Majid,

    Your second question was about the "ramifications of running it this way". This general approach of running a steady-state, or "pseudo-steady-state"  and then injection is the correct way to address such problems. Usually, it is advisable to first run the flow steady-state, then a chemical pseudo-steady state (if mineral kinetics are involved it often isn't at a true steady state), so that you obtain an imperceptibly changing chemical system over the short time-scale of the injection, and then simulate the "perturbed" system, i.e., the injection. If the flow is far from steady-state, and then the chemistry is run with mineral reactions there may be some unrealistic early changes in chemistry that are not the same as those observed if the flow is already at steady-state.

    cheers,

    Eric

Content aside

  • 1 yr agoLast active
  • 2Replies
  • 75Views
  • 4 Following