0

Pressure reporting: Tgh2-ECO2M

Hello ECO2M users,

It is about pressure reporting of Tough2 when running a 1D radial model initialized with only water, flooded by CO2 at Its center using ECO2M.  I get the following curves.

 

While expecting the pressure at initial part to be at the same level as the picked values and be continuous.

 

Is it a reporting issue here? It is a bit difficult to make sense of it. Input and output files are attached. Running the same model with different rel perm and capillary behavior gave negative values for the same initial part, see output file itgh_Sg_P_T_S.col.

Other outputs like saturations, temperature, etc. don't seems to have such discontinuity- at first glance.

Appreciate your feedback.

Godarzi

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Godarzi.

    I tried your input file with T2Well-ECO2M, of course with no wellbore flow.

    The P vs log(radius) at 1 year is shown below.

    In your input file I noticed that you have omitted the phase index, which for stated aqueous conditions should be 1.

    You have also used X3=10.00001 which is a wrong initialization, as X3 should be the mass concentration of CO2 in the aqueous phase. As a guess I used X3=0.00001.

    INCON----1----*----2----*----3----*----4----*----5----*----6----*----7----*----8
        1                         
               7000000.0            0.000001            10.00001                35.0

    Regards,

    Alfredo

    Like
  • Thank you Alfredo taking your time to run and examine this.

    Could you please be more specific where in input file you mean I have to specify phase index. I asked for pressure output using the iTough commands with either "PRESSURE" or "AQUEOUS PRESSURE", see attached file.

    Best regards

    Godarzi 

    Like
  • Hi Godarzi,

    I run your test example with tough3/eco2m without any problem. The simulation results look reasonable and can not duplicate your problem. 

    Like
  • Godarzi,

    I need to clarify my previous post. The ECOM version I used is V.2 by Lehua Pan which can simulate H2O-CO2-NaCl mixtures up to 300°C. It seems it is not able to accept the ECO2N style INCON format that you used. This is why I had to include the phase index in the INCON block, which is any way the standard ECO2M input.

    But you initialized your model in 2 phase (aqueous+CO2phase), not in single aqueous conditions as you wrote, by using X3=10.00001= 10 + Sc. So, I guess the run with TOUGH3-ECO2M with ECO2N INCON style runs with the reservoir initially in two-phase conditions.

    Regards,

    Alfredo

    Like
  • Thank you Alfredo for clarification and both of you for assuring me that the problem is most likely a reporting problem- as I understand the results you have observed using either T2well/ECOM or Tough3/ECO2M.

    Best regards

    Godarzi

    Like
  • Apologize for the typo: I used T2Well-ECO2M (not ECOM).

    A.

    Like
Like Follow
  • 1 mth agoLast active
  • 6Replies
  • 30Views
  • 3 Following