Two time steps with restart gives different results than one without restart

Hello,

Do you know why a restart during 6 hours (for example) after one time step (6 hours for example) is different from one time step of 12 hours?

In my simulation with eos4, the results are different. In particular, the pH grows. The differences are even greater if multiple restart are done. Can it be a problem of kinetics?

Thanks,

Anthony

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Anthony,

    There are a few main causes for obtaining different results for different time-stepping. Overall it is due to the sequential noniterative scheme, however, other factors can come into play. First, if you have system that is advective (gas and/or water), then to get more accurate results you must set the Courant Number (rcour in solute.inp) to be less than 1.0 (preferably 0.5). This will make the transport more accurate, which is passed to reaction calculations that are then more accurate, and finally to porosity/permeability changes which will permanently affect the results, and feed back to the flow and transport. Exceeding the Courant number is the most likely cause of inaccurate and potentially wrong results, particularly since you are using EOS4 which likely involves has air/water vapor transport.  If advection is not the time-limiting process, then it could be that the reaction rates are too high for the time step, or that gaseous species diffusion is too fast for the time step. In either case, the best option is to reduce the maximum time step (in flow.inp) to a level where the results are minimally changed by further reduction of the time step. This can sometimes result in simulations that take a long time to run using a very small time step, but they are more accurate.  Also, make sure that the reaction rates and surface areas are reasonable for  the system you are modeling, since reactive surface areas in nature are usually orders of magnitude smaller than BET-derived areas in a lab.

    good luck,

    Eric

    Like 1
  • Thanks for your answer Eric.

    In my case, it is not a problem of Courant number but probably a problem of surface complexation calculus when restarting. I will look at reactive surface areas as you suggested.

    Anthony

    Like
    • Hi Anthony , have you got any update on this? currently i am having the same issue. I also use eos4. Thanks, Chenming

      Like
  • Hi Chenming Zhang , unfortunatly not! Sorry.

    Anthony

    Like
Like1 Follow
  • 1 Likes|like
  • 9 mths agoLast active
  • 4Replies
  • 608Views
  • 3 Following