Mass out problem of Sources/Sinks about drawdown

Hi everyone :

I am trying to pump water and create drawdown in TMVOC

I have a question about the pump water.

My pump water point is  below free water level 1m and want to create 1m drawdown.

I use big mass  to pump water. For example, i use mass out is 3kg/s ,it can run.

But when i want to create 2m drawdown and pump water point is  below free water level 2m.   I use the same mass out 3kg/s, it can't run.

Is there any limit about  the water level drawdown ?

I really don't have any idea where this problem is coming from. Any help is appreciated.


Ching Huang Wang   

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Ching Huang,

    There is no such limit. As always, I have to ask what you mean by "it can't run". What is the error message? I have a few thoughts on what may have gone wrong, but I do not want to guess (anymore). Please tell us what the error message is.



  • Thank you Stefan:

    Following picture is the end of the simulation and the file.

    I try to  pump water to create 2m drawdown below free water level 2m.

    I use three Sources/Sinks mass out is 1kg/s , the three Sources/Sinks is the same X axis and Y axis 10m distance interval 

    I can't find out where is the error message or something wrong with the simulation.

    Ching Huang 

  • Hi Ching Huang,

    Thanks for the additional information. Here are a few brief comments:

    (1) It appears you are using PetraSim and the version of TMVOC that is implemented into PretraSim, correct?

    (2) The PetraSim message is very instructive: “Please consult simulation output file 4.out” - that’s exactly what one should do to find the error message and analyze the problem, i.e., it is not sufficient to just consult the PetraSim visualizations and diagnostic plots.

    (3)  Looking at file 4.out that you sent, you find the relevant information above the last printout block; it says:


    It also tells you that the element causing problems is element 5735, and it is easy to find that the problem is related to the fact that the NAPL phase disappears in this element.

    (4) It is not that easy to resolve the issue. One "brute force" approach is to demand that at least TWO Newton-Raphson iterations be performed for each time step. I tried this and it worked, i.e., the simulation forced itself through the critical time around 143 time steps, and finished to the end. (I attach an excerpt of this run).

    (5) I do not know whether PetraSim offers this option of enforcing at least 2 NR iterations. It is easy to implement in case you have access to the source code.

    The key lesson here is that you have to look at the full output file and figrue out what may cause convergences issues.

    Good luck!


  • Thank your answer Stefan. 

    I'll try and figure out what's the problem cause convergences issues.

    If I have some questions I will still Questions.
    Ching Huang

Like Follow
  • 5 yrs agoLast active
  • 4Replies
  • 935Views
  • 2 Following