The input file I am using does not seem to be reading the INCON block. I am getting the following error:

+++++++++   CANNOT FIND PARAMETERS AT ELEMENT *00001*          XX(M) = 0.000000E+00 0.000000E+00 0.000000E+00 0.000000E+00
 }}}}}}}}}}} ERRONEOUS DATA INITIALIZATION }}}}}}}}}}           STOP EXECUTION----------
 excessive aqueous phase saturation change at element *00001*; initial Saq = 0.000000E+00

However, I have specified parameters for each cell in the INCON block. I believe my issue has something to do with my SELEC block, however I am not sure where to go from there. I have attached my output and input files, but I have reduced the amount of INCON and ELEM lines shown to reduce the total file size. Please let me know if you need any further information.

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I notice in your output file that files MESHA and MESHB exist.  This should only occur when you have not changed your ELEME and CONNE blocks (or MESH file) from the previous time you ran TOUGH3.  If you did change ELEME and CONNE, you will get very unpredictable results.  As a first try, delete MESHA AND MESHB and try running again.

      • Evan R
      • Evan_R.1
      • 9 mths ago
      • Reported - view

      Christine Doughty Hi Christine, thank you for the reply. This is helpful because I did change the ELEME and CONNE files slightly. I will keep this in mind for the future. However, I am still getting the same error. Do you have any other thoughts as to why this might be occurring?

  • I think there is an inconsistency in your input file.  I haven't used ECO2M for a while, and never in TOUGH3, but I found the following in the User's Guide.  If the block INDEX is present in the input file (yours is), then TOUGH3 expects to read INCON and PARAM blocks with a phase-identifying index present (ECO2M-style initial conditions).  In the PARAM block the index is on the line before the default initial conditions.  In the INCON block it is on the line with the element name and porosity.  But the index variables are not present in your input file.  If you want to initialize your problem using ECO2N-style initial conditions (which I think you could, since you have no CO2 in your problem to start), remove the INDEX block (it is just one line) and the code will not be looking for the index variable in PARAM and INCON.  If you do want to use ECO2M-style initial conditions, keep the INDEX block, and add the phase-identifying index in PARAM and INCON.

    By the way, I recommend setting MOP(1)=1, MOP(5)=3, and  MOP(7)=1 in your input file.  These are flags that add helpful information to your output file.

    Also, I don't think there is anything wrong with your SELEC block, since you are using all default values.

    Finally, for extra credit, try to figure out about why your run failed claiming all state variables are zero.

  • I just thought of one more thing.  Your first element name is 00000.  This makes me kind of nervous, since TOUGH can read zeros as blanks and vice versa.  If you or other users have had success with an element named 00000 maybe it is fine - I've just never done it.

  • In addition to what Chris' said, I am not sure if the error was generated using the input file attached. I downloaded the input file, it seems: 1 you have 5 un-connected elements, 2. the connection in the CONNE are useless since one of the elements in each connection does not appear in ELEM. 3. Elements in GENER are not used. Those are the messages I got when I run.


    The output INCON file seems fine.


Like Follow
  • 9 mths agoLast active
  • 5Replies
  • 40Views
  • 3 Following