Compiling against more up to date PETSC version

Hi All,

Just a question regarding compiling TOUGH3 against a PETSC versions higher than the 3.7 branch. Has anyone tried this? Is it possible? I know at some stage a number of the PETSC function calls changed. This has broken some of my other codes. If anyone has any experience of compiling against a higher PETSC version I would love to know.

 

Thanks for your help,

 

Gareth

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello Gareth,

    Compiling TOUGH3 with higher version of PETSC needs modification of the source code. One of our collaborators did some modifications to have TOUGH3 work with PETSC 3.12.5. It was tested on a couple of problems, but not widely tested yet. If you want to give it a try, please contact me at yqzhang@lbl.gov

    Thanks

    Yingqi

    Like
Like Follow
  • 9 mths agoLast active
  • 1Replies
  • 29Views
  • 2 Following