gravity-capillary equilibrium in EOS3

hello,

 

I am using EOS3 (TOUGH3-eos3 windows executable) to simulate a gravity capillary equilibrium along a 1-D column but I keep running to convergence failure issue.

I was able to successfully simulate this problem in EOS7 but for some reasons that I cannot figure out, it’s not converging in eos3.

 

I was hoping if you could please take a look at my input and let me know what is wrong.

 

Attached are my input and output.

 

Thanks and best regards,

Alborz Fathinezhad

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • to anyone who might be interested,

     

    I modified/deleted unnecessary blocks in the input and tried it again on my WINDOWS machine and I ran to the same errors, while I tried it on a HPC (LINUX machine) and it converged to the end of simulation.

     

    bests,

    Alborz 

    Like
  • Hello Alborz,

    I took your input file without any modification and run it on my windows 10 pc (with the pc executable in the package we released), I got an error message:

     $$$$$$$$$$ LIQUID PHASE DISAPPEARS AT ELEMENT *A11 1*  $$$$$      SG = 0.105000E+02
     !!!!!!!!!!! ERRONEOUS DATA INITIALIZATION !!!!!!!!!!           STOP EXECUTION----------
     +++++++++   CANNOT FIND PARAMETERS AT ELEMENT *A11 1    *          XX(M) = 0.000000E+00
     

    Then I notice you set MOP(19)=1, which used a different set of initialization for primary variables. I re-set MOP(19)=0. It runs all the way to the end without any problem.

    My question to you is: when you run it on pc, did you use the executable in the package you purchased or did you make one yourself? if you made one, what compiler did you use?

    I attach the input and output file from my run.

    Thank you, Yingqi 

    Like
  • dear Yingqi,

     

    I was using the executables that came with the packages.

    also, per your advice, I changed mop(19) to 0 and it converged.

     

    thanks for your help,

    Alborz

    Like
Like Follow
  • 8 mths agoLast active
  • 3Replies
  • 42Views
  • 2 Following