Difficulties with AssignRock

Hi everyone,

I have some difficulties using AssignRock.

I generated the mesh, with MESHMaker (see file attached), corresponding to the problem n°7 in the TMVOC user's manual. You can find the MESH file attached.
I tried to assign rock names to elements using AssignRock but it does not work.

Here is how I proceeded:
- launched AssignRock with a Windows prompt command;
- input MESH file is MESH;
- output MESH file is MESH2;
- domain shape is 1) cube;
- rock type name is SAND3;
- I then typed the region coordinates (see the screen capture attached).

AssignRock does not assign SAND3 to the corresponding elements, as you can see in the MESH2 file attached.

Could anyone help me and tell me what I did wrong please?Invalid file type 
Thank you in advance,


2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Quentin,

    Your box is outside the box! Your cube is in positive Z territory, whereas your Z-coordinates in MESH are all negative. Specify Zmin=-5 and Zmax=-0.001, and it works as expected - it actually worked as (I) expected in your case as well...


  • Thank you Stefan,

    It works fine now.

    I knew it was something quite simple... Well, not simple enough for me, though! : )


Like Follow
  • 7 yrs agoLast active
  • 2Replies
  • 633Views
  • 2 Following