0

Simulation stops automatically at (9999,9)

Greetings,

I have developed a field scale stacked reservoir model to simulate the flow and transport of sc-CO2 in the subsurface. In my model, the domain is 1 km in lateral extent and vertically it is 50 meters, composed of 5 layers. The injection rate is 10 kg/s.

The model stops automatically while reducing time step at (9999,9) (Figure attacthed). In the modelling framework, I have selected maximum number of time step as infinite (Figure attached). Can anyone suggest why the model is stopping at this particular time step and not going beyond that?

4 replies

null
    • kenny
    • 1 mth ago
    • Reported - view

    you may directly edit the input file (INFILE?), let MCYC=-100. The code will run 2^(100) time steps after setting MCYC=-100.

      • Anith_Mishra
      • 1 mth ago
      • Reported - view

       Many thanks for your reply and suggestion. I tried to follow that, but it seems like MCYC can not be set to =-100 in the software directly, as it does not allow for a negative value and in the INFILE, I could not find a parameter called MCYC. I have attached an INFILE from the simulations that I have ran so far. Can you please help me on this?

      • Mohammadjavad_Shokriafra
      • 1 mth ago
      • Reported - view

       Hi, instead of 9999 highlighted in the snippet below, put -100 or any other negative values. the number of timesteps will be 2^100 as Kenny suggested. I used -30 and it worked for me.

      • Anith_Mishra
      • 1 mth ago
      • Reported - view

       Many thanks for your suggestion, it worked. I do have another question. Since I am working with heterogeneity in my models and that too in terms of capillarity, do you know of any methods by which I can speed up the processing time of the simulations? At this moment, some of my models are taking 8-10 working days to run into completion.  

Content aside

  • 1 mth agoLast active
  • 4Replies
  • 39Views
  • 3 Following