Compiling TOUGH3 on Linux platform (Ubuntu)

Hi everyone,

First of all, I wish a happy new year!

Secondly, I have trouble compiling TOUGH3 on an Ubuntu platform and I am wondering where I could find instructions for compiling TOUGH3 on Ubuntu.

Thank you very much in advance for your help,


8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Quentin, I just successfully installed UbuntuTerminal on a Windows 10 machine and compiled TOUGH3.  I have some readme files that I would like to send you. Can you send me your email address so I can send them to you to test?  We can post the readme files on the website if you find them useful.  Thanks.  -Curt   cmoldenburg@lbl.gov

      • Yu Zhao
      • Yu_Zhao
      • 3 yrs ago
      • Reported - view

      Curt Oldenburg 

          Dear Curt Oldenburg, 

          hello,i have TOUGH3 source code,and try to compile the code on Ubuntu v18.04,i just following the step in file "Read me_Linux"

         But on(56%)building Fortran Object step,an error occur:



           integer, intent(out), optional, dimension(MPI_STATUS_SIZE) :: status
                                                                   <font color="#EF2929"><b>1</b></font>
      <font color="#EF2929"><b>Error:</b></font> Symbol ‘<b>mpi_status_size</b>’ at (1) has no IMPLICIT type


       i attach the compiling log in attaching file.

       i don't know which step did i make mistakes.

      Any help on figuring out the root of this problem would be much appreciated.

      Thank you.

      Best Regards

  • Dear Yu,

    Please give a try to what I describe in the attached.  Your Linux may be different from the Ubuntu Terminal I installed, but it may also be that the same steps will work for both.  Note that some errors and warnings do arise during the long installation processes described in the README attached, and that my machine took probably two hours to install all of this stuff while I sat by and monitored its responses.  So be patient. Let me know how it goes.

      • Yu Zhao
      • Yu_Zhao
      • 3 yrs ago
      • Reported - view

      Curt Oldenburg 

      Thank you for your prompt response.

      i have built tough3-eos9 successfully following "Read me Linux".Build with parallel with type of release.My compiling environment is :ubuntu18.04,cmake3.8.2, gcc7.3.0,mpich2-1.2,TOUGH3v1.0.

      There are three errors occurs while Compiling:

      (1)the first error occurs while [21%]Performing download step (download, verify and extract) for 'BLAS' ,i check the TPLversion file in esd-toughlib/tpls,its original code shows in pic1, i Edit it to pic2,and this error fixed.(first i tried newest blas version v3.8.0,and still failed in [ 32%] Performing install step for 'BLAS',so i changed it to V3.5.0,and succeed)


      (2)the second error occurs while [ 45%] Performing configure step for 'petsc',the petsc can not successfully configured with the option "download -f-blas-lapack=1"in petsc-configure-step.sh.in file located at esd-toughlib/tpls/templates,so i manually changed the code to "download -f-blas-lapack=1"to“download -fblaslapack=1”,and this error fixed(pic3 && pic)(i don't know why, i just did this and its do work)


      (3)the third error occurs while [56%]Building Fortran object src/mpi_interface/CMakeFiles/toughlib_parallel.dir/parallel.f90.o,this error occurs due to my environment,i think. Because original mpich version i used is mpich-3.2.1,and this error shows,then i completely remove mpich-3.2.1 in my system and install mpich2-1.2,a older version,and this error fixed.


      These are the three questions i had during my compiling. i use this parallel executable tough3-eos9 to test a complex model in server,and its perfect.


      Also i have used the three files you give me this afternoon,and still have some problems in [100%]linking step,i am still working on it,before this, an error do occus with "./compile_T3_Ubuntu.sh: 行 33: --implicit-blaslapack: 未找到命令".it seems like that the CMake can not find this order(pic5),so i just manually edit these options in configure.sh.


      Again,Thank you for your prompt response.


      Best Regards.

  • Hi Quentin,

    I am struggling the same issue. Did you get Tough3 installed on your Ubuntu?



  • Alborz,

    This is in the readme_ubuntu_terminal3 document, and this particular text block  came from Quentin:

    If compilation fails with script error, “Failed to build TOUGH TPLS”,

    Go to the directory esd-toughlib/tpls

    Type vi TPLversions.cmake to edit the file

    Look for a line that says set(PETSC_VERSION_PATCH 6)

    Change 6 for a 4


  • dear Curt,

    thanks, it is solved but I ran in to another errors which are:

    Function ‘parallel_irecv_cv’ at (1) has no IMPLICIT type

    Function ‘parallel_isend_cv’ at (1) has no IMPLICIT type

    what should I do now?



Like Follow
  • 3 yrs agoLast active
  • 8Replies
  • 376Views
  • 4 Following